ABBUC Newsletter vom 04.10.2000

MegaRAM III

Hi Leute …

Eine wichtige News für alle User einer MegaRAM III!

Hi,

(please feel free to translate this INTO English for the Newsgroups)

nachdem ich es endlich geschafft habe, dem Draengen der Atari-User
nachzukommen und ein paar Speichererweiterungen vom Typ MegaRam III
zusammengebaut und verkauft habe, stellte sich nun doch noch ein Fehler
heraus, obwoh ich sie vorher zu Hause getestet habe.

Auf dem Testrechner (einem XE) funktioniert sie auch bislang fehlerlos.

Allerdings funktioniert sie nicht richtig auf Rechnern vom Typ XL.

Wenn man das weiter untersucht wird man vermutlich herausfinden, dass
sie auf Rechnern mit FREDDY funktioniert und auf Rechnern ohne FREDDY
nicht, aber das kann ja testen wer will.

Nachdem ich jetzt mehrere Tage (ganze Tage meiner Freizeit) die
MegaRam III auf dem OP-Tisch hatte, scheint es so, als haette ich
den Fehler und eine Loesung für das Problem gefunden.

Der Fehler ist der gleiche, der auch schon die MegaRAM 2 nicht
funktionieren liess – der Refresh funktioniert nicht, und zwar
weil der Erbauer der MegaRam den Refresh nicht korrekt eingebaut
hat.

Lösung: (s. beiliegende Grafik)
=======
Die MegaRam III wird auf automatischen Refresh umgebaut. Dafuer braucht
man:

– 1 AND Gate (74 LS 08)
– etwas Draht (am besten Kupferlackdraht)
– Loetgeraet

An der Stelle „X“ wird der Widerstand von der Platine getrennt.
Der Pin des Widerstandes kommt an des Ausgang des UND – Gatters.

Der Loetpunkt, wo der Widerstand war, kommt an einen der Eingaenge
des UND – Gatters.

Der Pin 10 (markiert mit „(3)“) des 74 HC 4040 wird mit dem zweiten
Eingang des UND – Gatters verbunden.

Fertig. Das wars.

Wer besonders gründlich sein möchte, legt noch die restlichen Eingaenge
des 74LS08 auf Masse.

Gruß, Erhard